1. What is the difference between a Robot Project and a Virtual Instrument?
Top of Form
                                                             
features an enhanced interface that allows you to configure and
test your robot without a program, as well organize multiple program files in one place.
Bottom of Form
Top of Form
                                                            
 contains a single Front Panel and Block Diagram, and can be used
to create a single program and interface.
Bottom of Form
2. For this question, refer to the two pictures below:
[image: http://curriculum.cs2n.org/lv1/unit1/question_images/screen_frontPanel.png] [image: http://curriculum.cs2n.org/lv1/unit1/question_images/screen_blockDiagram.png]
b. What is the window on the left with the grey background called?
Top of Form
The Block Diagram
The Main Menu
The Program Field
The Front Panel
Bottom of Form
b. What is the window on the right with the white background called?
Top of Form
The Block Diagram
The Main Menu
The Program Field
The Front Panel
Bottom of Form
b. Which window do you drag VIs into, to give the robot movement commands?
Top of Form
The Front Panel
The Program Field
The Block Diagram
The Code Schematic (not shown above)



3. What is this called?[image: http://curriculum.cs2n.org/lv1/unit1/question_images/block_motorFoward.png]
Top of Form
A Movement VI
A Motor Control VI
A Forward VI
The Block DiagramBottom of Form
4. If you want to add a Motor VI to your program...
a. Where can you find one?
Top of Form
[bookmark: _GoBack]In the Tools Palette
In the Functions Palette
Type the word "Motor" and press enter
In bar on the left hand side of the screen
Bottom of Form
a. How do you add it to your program?
Top of Form
Double-click the Motor VI in the Functions Palette
Drag the Motor VI to the Front Panel
Drag the Motor VI to the Block Diagram

5Bottom of Form
5. How do you open the Functions Palette?
Top of Form
Right-click an empty area of the Block Diagram
Select Functions Palette from the View menu
Both of the above
None of the above
5Bottom of Form
6. What command does this block give the robot? [image: http://curriculum.cs2n.org/lv1/unit1/question_images/block_motorFoward.png]
Top of Form
Forward a message to the robot
Turn the motors on in the foward direction
Wait for 1 second
Stop the motors
Bottom of Form
7. What command does this block give the robot?[image: http://curriculum.cs2n.org/lv1/unit1/question_images/block_motorBreak.png]
Top of Form
Make the robot fall apart
Turn the motors on in the foward direction
Wait for 1 second
Stop the motors
8Bottom of Form

8. What does the pink wire indicate in this program?[image: http://curriculum.cs2n.org/lv1/unit1/question_images/command_moveUntilTime.png]
Top of Form
The blocks were dropped too close together
LabVIEW is currently running the commands
The commands will take place in order they are connected from left to right
This is the Primary Command Sequence for the robot
9. Bottom of Form
5. The two blocks shown below were dropped far apart and did not auto-wire. How do you connect them?
Top of Form
Click their top corners and use the wiring tool to connect them
Drag them closer together until the auto-wire appears
Right-click the first block and select "Wire to Nearest"
You can't wire them together if you miss the first time
10. Bottom of Form
6. Which button in the picture below that Runs the program.
Top of Form
[image: http://curriculum.cs2n.org/lv1/unit1/question_images/screen_moveFoward.png]
11. What is a Constant (also called a Constant Modifier)?
Top of Form
A command that tells the robot to hold its position
Any command given to the robot that does not change its heading
Another name for a Variable Block
A "thing" representing a specific value, which can be wired into Blocks
12Bottom of Form
12. How do you set a motor to run for 5 seconds instead of 1?
Top of Form
Click the Motor Block and change the Duration setting to 5
Wire a Constant with a "5" in it into a Motor Block's "Time" port
Create a Constant with a "5" in it and drag it on top of the Motor Block
Drop a 5 Second Motor Block on the Block Diagram instead
Bottom of Form
13. Where would you check to see what settings are available on a block and what they do?
Top of Form
Context Help window
Block Diagram
Front Panel
Main Menu
1. 
Bottom of Form
14[image: http://curriculum.cs2n.org/lv1/unit1/question_images/REM_direction_reference.png]
What ports are the robot's motors attached to on the default REM model?
Top of Form
Left Motor=A, Right Motor=B
Left Motor=B, Right Motor=C
Left Motor=C, Right Motor=B
Wheel Motors=C, Arm Motor=B
Bottom of Form
14. Why are Rotations generally better than Time?
Top of Form
The robot's clock is inaccurate
The wheels spin more freely
Rotations always go the same distance regardless of speed or battery level
You cannot set the number of seconds the robot waits
Bottom of Form
15. [image: http://curriculum.cs2n.org/lv1/unit1/question_images/motor_context_help.png]
According to this picture from the Context Help menu, which of the following things can NOT be chosen on a Motor Block?
Top of Form
How long to keep the motors running
Which motor ports to give the command on
How much power to give the motors
All of the above can be set on the Motor Block
Bottom of Form
16. Based on the same picture from the Context Help menu in question 4, what is the default value for the Power setting on the Motor Block?
Top of Form
75
100
All Ports
No default
Bottom of Form
18. How do you make a program that can run on the NXT without needing to be hooked up to the main computer?
Top of Form
Select "Target to NXT" from the File menu
Select "Send to NXT" from the Tools Menu
Choose "Run on NXT" from the NXT's LCD screen interface
LabVIEW programs cannot be run that way
Bottom of Form
19. Once you have deployed the program onto the NXT, how do you run it?
Top of Form
On the NXT: Program Files > Run
On the NXT: My Files > Software File > (Name of .VI file) > Run
On the PC/Mac: File > Run Deployed Program
On the NXT: grey button labeled "Run Deployed"
20. A robot turns when...
Top of Form
Its wheels move in different direction of at different speeds
You use a Motor Block set to Turn
You move the Steering slider to the left or right of center
Its wheels move together at the same speed
Bottom of Form
21. If the robot's left motor goes forward while its right motor goes in reverse, how will the robot's body move?
Top of Form
Turn to the left
Turn to the right
Move straight ahead
Make an outward spiral
Bottom of Form
22. To make the robot turn...
Top of Form
Change "Fwd" to "Turn" on the Motor Block
Move the steering slider to the left or right
Make an outward spiral
Give its wheels different movement commands
Bottom of Form
23. If you don't specify a motor, what does the Motor Block default to?
Top of Form
Motor/Port A
Motor/Port B
Motor/Port C
All motors/ports
Bottom of Form
24. To specify which motors a Motor Block controls, you:
Top of Form
Attach a Constant modifier to the Output Ports node
Change "Fwd" to the name of the motor you want
Use a "Motor A Block" instead
Select the Motor Block and type the letter of motor you want (A, B, or C)
Bottom of Form
25. How do you remove a wire?
Top of Form
Drag the blocks apart until the wire breaks
Click on the wire and press delete
Use the scissors tool to cut the wire
Hold down the mouse button and scratch it out


26. 
What does the Sequence Structure do?
Top of Form
Let the program choose between multiple "frames" of code to run
Let the program repeat "frames" of code more than once
Let you hide code that you don't want to run
Allow "phases" of code to run in sequence even if individual    phases involve parallelism
[image: http://curriculum.cs2n.org/lv1/unit2/question_images/q_constants1.png]
27. What is the value of this Constant circled in red above?
Top of Form
0
3
4
No value
28Bottom of Form
27. How is the circled Constant being interpreted by the program?
Top of Form
As a command to wait
As number of port
As a number of rotations
As number of seconds
Bottom of Form
28. Why is it being interpreted this way?
Top of Form
Because it is providing its value to the Wait Block
Because it is providing its value to the "Seconds" terminal on the Wait Block
All constants are interpreted the same way
Because the value is an integer
Bottom of Form

29. What does the Light Sensor detect?
Top of Form
Length of darkness
Intensity of red light
Robot's weight
Robot's speed
Bottom of Form
30. Which would produce a HIGHER light sensor reading with a light sensor pointed at it: a dark surface or a light surface?
Top of Form
The light surface
The dark surface
Both the same
No reliable pattern
31.
How do you view the numeric values coming from the sensor?
Top of Form
Attach a digital lead to the robot
Use the View Mode on the NXT screen
Click on the Sensor Block in LabVIEW
Look closely at the back of the sensor
Bottom of Form
32. What Block tells the robot to wait for a Light Sensor reading lower than a certain cutoff threshold?
Top of Form
Wait Block set to Wait for Light > Darkness
Sensor Block set to Light Sensor > Darkness
Wait Block set to Wait for Light > Darker
Wait Block set to Wait for Light > Lightness
Bottom of Form
33. How do you calculate a suitable Light Sensor threshold value?
Top of Form
Use the value from the Light surface
Use the value from the Dark surface
Use the Find Threshold Block in LabVIEW
Halfway between Light and Dark values
Bottom of Form
34. How do you specify the cutoff value for determining "Dark" from "Light"?
Top of Form
With a Light Sensor Modifier attached to the Threshold wiring node on the Motor Stop Block
Activating View Mode automatically stores the correct value
With a Constant Modifier attached to the "Darkness" wiring node on the Wait Block
By clicking the Wait Block and typing in the value
35. What does the Sound Sensor measure?
Top of Form
Sound wavelength (pitch)
Sound intensity (volume)
Sound frequency (pitch)
Distance to the nearest object







Bottom of Form
36. How do you specify the cutoff value for determining "Loud" from "Quiet"?
Top of Form
With a Constant Modifier attached to the "Loudness" wiring node on the Wait Block
Activating View Mode automatically stores the correct value
With a Sound Sensor Modifier attached to the Threshold wiring node on the Motor Stop Block
By clicking the Wait Block and typing in the value

37. Describe this program, block by block.
[image: http://curriculum.cs2n.org/lv1/unit2/question_images/q_command4.png]
Top of Form
Move forward on Port B, move reverse on Port C, wait for 10 seconds, stop
Move reverse on Port B, move forward on Port C, wait for 10 seconds, stop
Move forward on Port C, move reverse on Port B, wait for 10 seconds, stop
Move forward on Port B, move reverse on Port C, wait for 10 milliseconds, stop Port A
Bottom of Form
38. What will the program do to the robot?
Top of Form
Move reverse for 10 seconds
Move forward for 10 seconds
Swing turn for 10 seconds
Point turn for 10 seconds







39. Bottom of Form
39. Describe this program, by sequence.
[image: http://curriculum.cs2n.org/lv1/unit2/question_images/q_command5.png]
Top of Form
Closes claws, move forward for 2 rotations, then opens claw
Opens claws, move forward for 2 rotations, then closes claw
Opens claws, move backwards for 2 rotations, then closes claw
Opens claws, move forward for 2 degrees rotation, then closes claw

40. What does it mean for two strands of code to run "in parallel"?
Top of Form
They are placed side-by-side on the diagram
They both START running at the same time
They both START AND STOP running together
They take turns running blocks
Bottom of Form
41. These two strands of code run in parallel because
[image: http://curriculum.cs2n.org/lv1/unit2/question_images/q_fruitpicker2_1.png]
Top of Form
They both contain Motor Blocks
They are placed side-by-side on the diagram
Both are independent strands with no wire leading into them
Bottom of Form
42. When this first strand of code finishes, the second strand:
[image: http://curriculum.cs2n.org/lv1/unit2/question_images/q_fruitpicker2_1.png]
Top of Form
Is unaffected because the two are independent
Stops immediately
Starts running twice as fast
Skips ahead to the last block in its strand
43. What does the Sequence Structure do?
Top of Form
Let the program choose between multiple "frames" of code to run
Let the program repeat "frames" of code more than once
Let you hide code that you don't want to run
Allow "phases" of code to run in sequence even if individual phases involve parallelism

Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
Bottom of Form
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